Upgrade PHP 8.1

Share

ตอนนี้ wordpress มันเตือนมานานแล้วว่าระบบของเราใช้ PHP version เก่า (7.1) และอาจจะเป็นอันตรายต่อความปลอดภัยว่าจะถูก hack ได้

เลยจัดการ Upgrade เลยเป็น PHP version 8.1

ปรากฎว่า พังเลยจ้าา…
ปัญหาคือ
1. wordpress มองไม่เห็น php version 8.1 เนื่องจาก PHP-FPM ถึงเป็นตัวกลางการทำงานของ NGINX กับ PHP ถูก setup ไว้ให้วิ่งไปหา php 7.1

2. phpMyAdmin เข้าไม่ได้ ขึ้น Internal Server Error 500 แก้ไขโดยการ Update phpmyadmin เป็น version 5.1.3 ก็หายขาด

3. ก่อนหน้านี้ลง php 8.1 ไม่ผ่าน เลยทิ้งไว้ 3 เดือน เหตุเนื่องมากจากลงคำสั่งผิด ดันไปเอา package ของ Ubuntu มาลง ทำให้ config มันเพียนๆ โหลด package ไม่เจอเยอะมาก แก้ไขโดยการเข้าไปลบ server ที่จะ link เข้า ubuntu package ออกให้หมด

ยังมีเว็บ opencart ที่ลงไว้ว่าจะเปิดร้าน แต่ก็ยังไม่ได้เปิด ก็พังอีก เดี๋ยวพรุ่งนี้ตามเข้าไปดูอีกทีครับ

This entry was posted in ข่าวสารของ chokelive and tagged , , on by .

About chokelive

ชื่อโชคครับ นักวิทยุสมัครเล่น callsign E29AHU ชอบทดลองวงจรอิเล็กทรอนิกส์ เขียนโปรแกรมคอมพิวเตอร์ ชอบตื่นเช้าๆ มาดูพระอาทิตย์ขึ้น และชอบ drip กาแฟแบบเข้มๆ ติดต่อผมได้ที่ chokelive [at] gmail.com

Leave a Reply

Your email address will not be published.